Topic: Any other ways to fix nat type D on switch?

Posts 1 to 1 of 1


So starting off i will give you some info on how my wifi is setup and then steps i took in order to fix my nat type D issues. So i have a fiber connection going to a modem which then connect to my ISP router (zyxel VMG8623-T50B) and then a cable going from the lan port to the wan port of my secondary router (Tenda AC10U). Im using a second router due to my ISP router not having a good signal all the way to my room. And now i will give some insight to some steps i took to maybe fix it:

1. I port forwarded the following ports on my ISP router (45000-65535 couldnt do 1-65535 due to this error message "The configured port range including the Connection Request port is not permitted.") and connected my nintendo switch on it . At first without my switch having a static IP but the second time i did put a static IP (both methods didnt work and even though many sites say my ports are closed my switch instantly showed the nat type which was D i dont know if it has any meaning but it didnt show that fast before + even if it work my internet is too slow meaning even getting nat type A i would still have issues connecting to multiplayer games)

2. Did exactly the same as the first step but on my second router (Tenda AC10U) i put 45000 on the LAN port and 65535 in the WAN port i even did 1 in LAN port and 65535 in WAN port (LAN & WAN ports reffering to virtual server) also did the same thing with setting up a static IP on my switch (didnt work

3. Tried DMZ on both routers. When setting the DMZ for my switch on my Tenda router it doesnt work but on my ISP router it works but its not consistent and i may get nat type A/B for a couple hours or a day but then it wont work again + i dont feel confortable using DMZ

4. I tried putting my Tenda AC10U as an access point which didnt work and then as a wireless repeater which i wasnt able to get right cause i had no idea where to find the upstream key.

5. And the last thing i did was to port forward 45000-65535 from my ISP to the IP of my Tenda AC10U (the IP that my ISP router shows) and procceded to port forward the same ports on my Tenda AC10U while my nintendo switch was connected to it and had a static IP.

So if anyone got any ideas it would be great. I have done quite some reasearch and i saw it could be a cg-nat or that my ISP blocks certain ports meaning i will have to contact them but even then i dont know what exactly to tell them. Some say to ask them for a public or static IP and other if it's possible to open certain ports or ask them if there is any nat type problem from their side of things.


  • Page 1 of 1

Please login or sign up to reply to this topic