Topic: I can't turn on my NS

Posts 1 to 8 of 8


I can't turn on my NS it show only nintendo logo then it disappear, and that's all. I'll try to reset console by pressing power button, more then 12 seconds but I've got still same problem after that. Thanks for help.



@Seheran Could it be that the battery needs charging? If so, try leaving it in the Dock for 10-15mins and see if you can turn it on afterwards

ūüéģ Adult Switch Gamers: Thread | Discord | Guilded

Switch Friend Code: SW-0427-7196-3801 | Twitter:


@Seheran I'm much too lazy to find it, or to try to remember details but search for a thread created by me last May or June regarding a switch problem, or switch power issue or something like that. I had a really weird issue with one of my 2 switches much like you describe. No matter WHAT I did, I could not get it to turn on. I tried every trick. It would (sometimes) show the Nintendo logo and vanish. I tried a bunch of tricks (documented in that post) and the normal fixes didn't seem to work. But eventually after an hour or two of monkeying with it, just when I had given up and accepted I had to send it in for repairs and probably lose my save data, it came back, and over a year later with daily use, knock wood, it's never happened again. It was some weird software induced glitch state of some kind I presume and the trick is just to get it to actually reset itself in a way that matters.

You could have a more serious hardware issue, but it's very possible you had the weird state I had and just need to get it to properly reset itself.

Edited on by NEStalgia



@Matthew010 Thank you for doing my work for me. I'm slightly ashamed someone else had to do it for me. Only slightly.



I once had my switch suddenly refusing to turn on. It worked again after I left it charging for a while. (As far as I remember it wasn't low on battery when it happened, but that fixed it)

Edited on by Eel


My dead channel.

SMM2 Maker ID: 69R-F81-NLG

My Nintendo: Abgarok | Nintendo Network ID: Abgarok


  • Pages:
  • 1

Please login or sign up to reply to this topic