Forums

Topic: Wifi keeps dropping on new Switch

Posts 1 to 12 of 12

chris_35

I have a new swtich (week old) and i have noticed that a few times a day (3-5) the wifi will drop out for a minute. This is so frustrating when trying to play online games as i get booted out.

I assume this isnt normal behaviour, i have a ton of devices (laptops, google homes, phones, tablets etc etc) and none of them suffer from this problem ever, so its not the router.

Im guessing its a case of talking it back and getting a replacement, but wanted to check that there isnt a known issue first with a quick fix?

Also im new to the swtich and got an online account, if i do have to take it back and exchange, is it easy to put my online account to the new swtich?

Thanks all

chris_35

Laserbeak1982

@chris_35 It could be the Router. I've had this issue before with other devices and found it was the Router and had to tweak things on channels etc. Maybe prioritize the Switch connection on your Router ahead of other devices, that's a good starting point.

Laserbeak1982

WoomyNNYes

@chris_35 It may not be your Switch. I've seen a couple people from the UK post about similar problems, and the solution was internet service/router related (compatibility issue) like Laserbeak1982 mentioned above. So, search nintendo support's page for internet connection/wifi issues. Or contact nintendo support. As of last summer, nintendo support UK hid their their phone number. The phone number would be revealed at the bottom of the contact page's email form. It was sneaky. (I'm in the US, and since September 2021, nintendo UK contact page seems region locked, won't let me access it anymore to confirm that.)

Edited on by WoomyNNYes

Extreme bicycle rider (<=click for video<3)
'Tendo liker
Rocket League (3v3 - platinum III/diamond I)

chris_35

Thank you both for your helpful replies, i will look into this ..thanks again

chris_35

SwitchForce

Restart your router and check for firmware updates. Since you didn't list make/model/firmware version no-one can do more to help here. Some router has limits to how many connections you can have before it has network clogging bandwidth issues.

Edited on by SwitchForce

SwitchForce

iLikeUrAttitude

While you're at it restart your switch as well, especially if your other devices aren't experiencing this issue.

Good... good
Now play Dragon Quest

chris_35

thanks, i have a virgin superhub 3

chris_35

NintendoDad

For me, when my microwave is on, it disrupts the WiFi for a bunch of my devices, like my cellphone.

Even the microwave at work does the same thing to my cellphone.

I guess ultimately, return and see if it keeps happening.

But, also . . . when it happens, see if there is anything that can be disrupting the WiFi, like a microwave or something.

NintendoDad

dew12333

I am with virgin and I constantly have one bar of signal, then I go into settings and ask to join the network and it goes straight up to three bars. This happens almost every time I start up the switch. In my opinion it's down to the crap virgin router that pushes all the signal to your tv box rather than other devises.

As I said before I tend not to have any issues after I rejoin the network.

Edited on by dew12333

dew12333

dew12333

Sorry just to add to my comment, this happens on my original switch and a switch lite, both the same.

dew12333

SwitchForce

Replace the Router with Retail that works for that network. This seems to be the issue but if your not going to get a different Router the same issue is going to happen over and over-nothing more anyone on here can help with.

Edited on by SwitchForce

SwitchForce

  • Page 1 of 1

Please login or sign up to reply to this topic