Forums

Topic: A problem with my switch

Posts 1 to 13 of 13

Spudward

So recently my switch has been acting weird in the dock, the screen will go black on the switch and the green light will come on the dock but nothing will display on my TV unless I turn the TV off and back on again whilst the switch has to be unlocked. Anyone else come across this and maybe have a solution. I've bought another dock and that hasn't fixed anything.
Edit: I found the issue, it seems to be something to do with how my switch connects with my TV, other TVs work

Edited on by Spudward

Spudward

SwitchForce

Check for updates and contact NSW support. No one on here can help with those problems here. If under warranty then you need to talk to NSW warranty support to fix it. Or take back to shop to exchange it if there is a problem with it.

SwitchForce

Spudward

What do you mean by NSW??

Spudward

Aven

I don't know if it's related but I had that problem with my PS4 and once with the Switch. It was due to my LG tv. Sometimes the HDMI port has trouble synching with whatever your connecting to it. I found taking out the HDMI lead and turning the TV off before reconnecting works fine

Aven

RayReliable

Well if the Switch is displaying after a TV restart then I would point fingers at the TV and it's HDMI detection. I would try it on another TV.

Switch Friend Code: SW-1157-2855-4408
PSN: RayReliable

Spudward

Yeah, I tried it on another TV and it worked fine, seems to be a problem with bush TVs and how they connect with the switch

Spudward

ccmsModel::load failed for: dgp:users/177865/avatar/0
ccmsModel::load failed for: dgp:users/177865/avatar/0
Alber-san

I have that problem too (sometimes), but the problem is solved simply by undocking and docking the switch again. Try that to see if it works.

Switch FC: SW-4227-6363-7321
Online games:
Rocket League, Splatoon 2, NBA Playgrounds, Fortnite

Favourite single player games:XC2, Skyrim, TLoZ: BotW

NEStalgia

@Spudward If it's not the dock, and if the Switch's screen displays fine, it's possible it's an HDMI issue between the TV and Switch as well.

NEStalgia

Spudward

@NEStalgia yes thank you, if you read up you'll find that I already found this out

Spudward

JMCCC

Sorry if tiny bit off topic but for anyone in the UK with hdmi problems this might be relevant. My Sky HD box was connected with a 5 metre good quality HDMI cable to my TV and always worked 100% with no problems. The Nintendo dock, when connected to the same cable would not work at all. When connected to the same cable via a powered hdmi matrix (switch box type thing) it worked perfectly. So if you are using a cable longer than the one supplied you'll probably need some sort of booster for it. NB - I think this is a pretty poor show if my ancient sky box can connect with a 5m HDMI cable and the Nintendo Switch can't.

JMCCC

Nemodius

try two things

1: I noticed on my tv, if I'm on the channel selection menu or on the HDMI channel, it does not show up, so I have to change over to broadcast, then after I put the Switch in the dock, I go to the menu and select the HDMI input

2: if that doesn't work, go to your Switch menu and look for the setting that synchronizes with your tv's power when you dock your Switch, see if that helps, if not, shut your tv off then redock your Switch

if those don't work, check that all the cords (HDMI & power) are fully inserted on both sides

hope helps man

"If failure is the greatest teacher, how come we are not the most superior beings in the universe ???"

SwitchForce

@JMCCC that's just one anadotal review so unless that can be repeated with the same cable with other Switch this is hard to verify. Just for FYI I bought three HDMI cables of the same make and they are 6feet and work just fine so your test doesn't add up if I got 3 6foot HDMI cables and they work just fine.

Edited on by SwitchForce

SwitchForce

  • Page 1 of 1

Please login or sign up to reply to this topic