Forums

Topic: Switch Faults??

Posts 1 to 10 of 10

OGriffG6

Hi.

So I've had this switch for a couple days now and it worked like any switch should work until recently. I tried turning it in the next day and the screen is completely black. I tried looking online for solutions such as hard resets but it doesn't do it justice, tried charging it, and more.

After all hope was lost I decided to put the switch into the dock and.. to my surprise it actually worked, it was able to show what was on the switch on the TV. However, if I take it back out it would just go blank again like nothing happened.

Sometimes after doing it a couple times I'm experiencing a weird problem when trying to put it into sleep mode too, when I do it, I wake up and it gives me the "power options, sleep mode" screen and the switch would instantly turn on again and won't be detected by the switch.. when it's off that page and on the "click home page to go to dashboard" page it will be fine.

However, in the odd chance I am off that page by pressing a bunch of buttons, I can tap my screen and hear the audio come out in handheld mode like the screen is meant to be on but its just a blank screen. I seen this to be a common problem, too.

On that note, when it doesn't give me the options to hear that audio, it won't let me turn my audio up/down, or read a game either. Almost like the switch is bricked but works?

It's confusing as hell as I've never experienced this in my life, and for an expensive console like the switch it should never do this.

Here's some diagnosing I tried to do:

  • When plugging in the switch with AC plug, I tried hard resetting it by holding down power button for 10-30 seconds and let go, pressed again (no luck), I sometimes pressed other buttons to such as "+ and -", or the home button as well as the power button but nothing happens.
  • same with normal cable as last point, nothing turns on.
  • Sometimes when I put the switch in docked mode it will flicker twice then give me a short solid light. It will then turn on then turn straight back off after 3 seconds. This is after I put it in sleep mode. I found somewhat a work around to this and that's to clean the charging port and the port for the dock (it just works). Sometimes it doesn't work.

I haven't tried going off that page because my joycons won't recognise the switch to turn on and when they do the screen switches off.

  • I tried turning the dock off by the wall and taking out my switch to see if that worked but doesn't.
  • I tried inserting a game and trying to play that to see if the screen magically works, but it does not.
  • I tried taking the joycons out whilst in docked mode but they don't properly connect anymore

That being said, my R joycon is messed up. It rarely turns on anymore, and it rarely connects to the switch. When it is turned on with the switch the green light on the side won't be visible half the time.

  • Tried factory resetting it
  • When joycons worked half the time I tried putting them back in the switch and taking it out of dock docked mode
  • Drained all the battery by not letting it go into sleep mode and turning it back on by pressing the power button for 10-30 seconds. Not only this didn't work, it also put me back to square one.

So other than the switch not showing any display and refusing any physical input, my right joycon is not charging (I think), turning on properly, syncing (at times) to the switch too.
Oh, and I did get this new.

Anyone got any suggestions so I don't have to pay for it, it obviously seems like a software problem than physical, and the problems I spoke about alter from time to time, like earlier everything worked but the power button and game cartridge (before I drained the battery)

Thank you for reading.

OGriffG6

Vincent294

I had the same, lost save data (thankfully not much), got new one from Nintendo. New one is happier.

Vincent294

My Nintendo: Vincent294 | Nintendo Network ID: Vincent294

Vincent294

Also after trying to troubleshoot I came back to it extremely hot as well. It seemed to be less than rare on forums. Definitely a hardware thing, my instinct was to update, but that was not the problem.

Vincent294

My Nintendo: Vincent294 | Nintendo Network ID: Vincent294

OGriffG6

@Vincent294 I might just have to do that if everything turns south. I got the switch to turn back on again as it is still turned on. The right joycon is refusing to charge though :/

OGriffG6

Vincent294

Mine eventually was unable to recharge before shipping to Nintendo.

Vincent294

My Nintendo: Vincent294 | Nintendo Network ID: Vincent294

OGriffG6

@Vincent294 was there any way you fixed it? I don't wanna pay or send it off haha. Don't have the receipt no more ūüė≠

OGriffG6

Vincent294

I didn't have the receipt and contacted Nintendo on phone or something, wound up going through UPS and paid half the shipping or something. I doubt your Switch is getting any better and my save data was not recoverable.

Vincent294

My Nintendo: Vincent294 | Nintendo Network ID: Vincent294

OGriffG6

@Vincent294 Damn! Well I found a couple of suspects which I'm going to start with tomorrow. Need to reseat the ribbon cable for both lcd and the joycon (as the right one is not working). If not, I'll send it out.

Looking online apparently you can open up the device without voiding the warranty but replacing parts does though so that's reassuring if I want to do anything on it

OGriffG6

SwitchForce

OGriffG6 wrote:

@Vincent294 Damn! Well I found a couple of suspects which I'm going to start with tomorrow. Need to reseat the ribbon cable for both lcd and the joycon (as the right one is not working). If not, I'll send it out.
Looking online apparently you can open up the device without voiding the warranty but replacing parts does though so that's reassuring if I want to do anything on it

Wrong opening up voids Warranty. Where are you looking that up AFAIK if you unscrew the Switch -
Warranty is voided no exception besides the Shop doing it. And sending back will insure you will pay for the repair.

SwitchForce

SwitchForce

OGriffG6 wrote:

Hi.

So I've had this switch for a couple days now and it worked like any switch should work until recently. I tried turning it in the next day and the screen is completely black. I tried looking online for solutions such as hard resets but it doesn't do it justice, tried charging it, and more.

Thank you for reading.

This is a matter of Warranty Repairs and opening it voids your Warranty and you pay for the repairs or replacements.

SwitchForce

  • Page 1 of 1

Please login or sign up to reply to this topic