Forums

Topic: HELP! Switch SLOW RESPONSIVE after the latest update :(

Posts 1 to 6 of 6

chobichisu

Yesterday, I played my Switch (docked mode) and updated the system before turning off the console. This morning, I notice that my Switch sometimes became so slow in response. The volume button works fine, but there are lags 5-6 seconds from each button I pressed. Sometimes the cursor is gone as well and the touch screen barely works. I wish I could attach a video here to show you guys, though... Does someone has any idea why this is happening? I never fell my Switch or hit it.

Edited: I also already updated my joycon. Tried to re-attach them to Switch, tried to restart the console and all, but no help.

Edited on by chobichisu

chobichisu

Balta666

Never heard of it but I would try to do a hard reset (without loosing data). To do that power off the system and press the on button for about 10-15s until you hear a bip. Release the button and press it again as normal

Balta666

GrailUK

Have you powered off the console? Sometimes that resolves issues.

I never drive faster than I can see. Besides, it's all in the reflexes.

Switch FC: SW-0287-5760-4611

chobichisu

@Balta666 I've turned my console off and do as you say, but there are no beep sound and all. It just turns on as usual and still face the same problem. Do you have any other way to do hard reset but without loosing any data?

chobichisu

chobichisu

@GrailUK I've tried but it won't work Btw all games play well, the slow and delay response only happening on the home screen

chobichisu

Balta666

@chobichisu my bad as I have said something wrong from memory. Don't turn the switch down as first step but while on hold the power button until I shuts down (again it should take between 10-15s). Wait a bit and turn it on again. If that does not work you should contact Nintendo support

Balta666

Top

  • Pages:
  • 1

Please login or sign up to reply to this topic