Forums

Topic: Left Joy Con not charging, but works when connected to the switch...help please!

Posts 1 to 13 of 13

Wa1k3r22

The left joy con for my switch isn’t charging. It connects to the console when it is attached and can be used to operate the console, play games etc but when you take it out it apparently has no power, won’t turn on at all. When connected to the console the controllers screen shows the charging symbol with small red section even when the console is not docked or plugged in, and this occasionally is flickering (the whole symbol not the charging level going up).
I’ve read a few posts and watched some videos and have tried the following;
Unpairing the controller and reconnecting, charging the console in the dock, charging the console direct with charging cable, updating the controllers. I don’t have a charging grip to try it with, only the console and I don’t have a receipt to send it off to Nintendo as it was a gift.
Can anyone help make a suggestion?

Wa1k3r22

SwitchForce

Did you try to update them and calibrate it? Otherwise you will have to contact NIN support for Joy-Con issues. NIN has informed NA can send it in for fix or replacement so you need to contact NIN.

SwitchForce

WoomyNNYes

@Wa1k3r22 If it was a gift, if their data shows that you were the first and only user of that Switch & it's serial number, it might be possible that Nintendo doesn't need a receipt. When you call Nintendo here in the US, they ask for your email to look up your nintendo account (that you made for eshop access). I think there's a chance Nintendo can see what your serial numbers is when they look in your account. I don't know this for certain, but it's possible. Nintendo's customer service is really nice, too.

Edited on by WoomyNNYes

Playing: Rocket League lately.
Science liker.
Extreme bicycle rider.
(Nobody says "extreme". I say it to be silly.)

OorWullie

@Wa1k3r22 I had that issue in the past but I forget what I done to fix it. I probably just reset the Switch and re-synced the controller,can't think what else I could have done.

So try fully powering off the console and sync the controller again. If that doesn't work, power off the console, unplug the power and HDMI cables and leave it like that for 5 minutes before powering on the console again. This is what Nintendo recommends on their website for a full reset if other options aren't working. Also, as mentioned above, try calibrating the controller again after doing this.

Good luck!

🇬🇧 Mr Mustard 🇹🇭
SW-6101-8403-1640

🕹️ The Nintendolife Arcade Leaderboards 🕹️

Heavyarms55

@Wa1k3r22 It's possible the battery got unplugged somehow, if you have the right screw driver it's pretty easy to open up and check the connection. If you're not sure how, there are plenty of videos that walk you through it on YouTube.

Nintendo Switch FC: 4867-2891-2493
Discord: Heavyarms55 / SW 4867-2891-2493#1475
Pokemon Go FC: 3838 2595 7596
PSN: Heavyarms55zx
Edelgard profile pic credit to: https://roselph.tumblr.com/

Wa1k3r22

Thanks, I have taken it apart to check and it’s all still plugged in correctly. @Heavyarms55

Wa1k3r22

SwitchForce

Wa1k3r22 wrote:

Thanks, I have taken it apart to check and it’s all still plugged in correctly. @Heavyarms55

Something I don't advise first doing unless it was dissembled prior. This is a Nintendo support issue now.

SwitchForce

Heavyarms55

@Wa1k3r22 That is extremely strange then. Does it turn off, or just not connect to the Switch?

Nintendo Switch FC: 4867-2891-2493
Discord: Heavyarms55 / SW 4867-2891-2493#1475
Pokemon Go FC: 3838 2595 7596
PSN: Heavyarms55zx
Edelgard profile pic credit to: https://roselph.tumblr.com/

Wa1k3r22

@Heavyarms55
It’s strange, the controller won’t turn on independently, like there’s no power in it at all. But when I attach it to the console it immediately pairs and can be used to control the system. The controller screen, where you can see the power and paired controls, shows an empty battery with slightest red line and the charging symbol, which is also odd because it shows even when the console is not plugged in and so not charging anything. It still doesn’t charge though, no matter how long it’s left on charge, in dock or direct to console.

Could the battery be dead, can the controller work plugged in without the battery?

Wa1k3r22

Heavyarms55

@Wa1k3r22 It seems possible that, somehow, the battery has gone bad. The only way to check that would be to get another battery, swap them, and test again.

Nintendo Switch FC: 4867-2891-2493
Discord: Heavyarms55 / SW 4867-2891-2493#1475
Pokemon Go FC: 3838 2595 7596
PSN: Heavyarms55zx
Edelgard profile pic credit to: https://roselph.tumblr.com/

OorWullie

@Wa1k3r22 Not sure if you tried my solution but I had the exact same issue as you a year or 2 ago and I'm pretty sure it was a full reset that fixed it. It's a software glitch, not a battery problem. There's even advice on what to do in this case on Nintendo's website,as mentioned in my post above.

Edited on by OorWullie

🇬🇧 Mr Mustard 🇹🇭
SW-6101-8403-1640

🕹️ The Nintendolife Arcade Leaderboards 🕹️

Wa1k3r22

@OorWullie I’ve tried this too, had it all unplugged for half an hour and no result it still shows the same

Wa1k3r22

Mixednoodle

I have the exactly same issue as you, please let me know if you find any solution, I am so frustated with it

Mixednoodle

Top

  • Pages:
  • 1

Please login or sign up to reply to this topic