Forums

Topic: Dock Port Not Connecting Easily

Posts 1 to 4 of 4

chargfox

I often have to keep reinserting the Switch into the dock before it finally makes a connection and starts charging. There's nothing wrong with it charging, it just doesn't always hit that initial connection just right. Pushing on it or trying to jiggle it won't make it connect. I have to actually lift it from the dock and reinsert it, sometimes several times, before it starts charging. Sometimes it hits it just right the first time. It's like the connector inside the dock is a hair off. Is this a normal behavior or there a way to fix this short of sending it for repair?

chargfox

GeoChrome

This has happened to me before, but usually because the AC adapter was not plugged in correctly. That could be the problem.

Reading: Berserk, Bungou Stray Dogs, Vagabond
Watching: ?
Playing: Ōkami

Switch Friend Code: SW-6148-2681-7704

SwitchForce

If this is under warranty then contact Nintendo support but have you tried to use this on another Dock to verify the problem? And you sure you check the cords were properly seated.

SwitchForce

chargfox

I tried checking for a loose chord but that didn't fix it. My daughter said my grandsons does the same thing and they have to unplug it for several minutes then plug it back up. That actually worked. If both are doing this, then it wouldn't be a broken system. I guess it just needs reset sometimes.

chargfox

Top

  • Pages:
  • 1

Please login or sign up to reply to this topic